Philips HUE White

Les ampoules Philips HUE peuvent être commandés par la box EEDOMUS.
Problème, le script fournit n’est compatible qu’avec les HUE Color.
Pour les HUE White, l’API de HUE permet de régler le problème :

Important !!!
Avec cette API, je gère les ampoules par groupe et non individuellement.
Donc la variable VAR3 doit être le numéro du groupe de vos ampoules.

Pour plus d’information : Documentation Philips HUE

  1. Ajouter un nouveau périphérique,
    Autre type de périphérique et sélectionner Philips HUE.
  2. Entrer les informations demandées pour la création des périphériques.
  3. Modifier les périphériques ainsi :

Exemple : mon plafonnier (Deux ampoules HUE White sur deux plafonniers).

1 – HUE White ON OFF

Paramètres expert (pour la mise à jour du périphérique ON OFF)
Le Chemin XPATH doit être : state/all_on

HUE White ON OFF (valeurs)
Mettre exactement les mêmes valeurs brutes pour avoir un retour d’information correct.

2 – HUE White Intensité

Paramètres expert (pour la mise à jour du périphérique de l’intensité)
Le Chemin XPATH doit être : concat(round((action/bri) div 2.54),’%’)
J’ai galéré pour trouver la bonne formule 🙂

HUE White Intensité (Valeurs)
Mettre exactement les mêmes valeurs brutes pour avoir un retour d’information correct.

3 HUE White couleur

Paramètres expert (pour la mise à jour du périphérique Couleur)
Le Chemin XPATH doit être : action/ct

HUE White couleur (Valeurs)
Mettre exactement les mêmes valeurs brutes pour avoir un retour d’information correct.

 

Vous avez maintenant trois périphériques pour gérer vos ampoules HUE White.

Je suis à votre disposition si vous avez des remarques sur ce tuto.

 

 

 

 

5 réflexions au sujet de « Philips HUE White »

  1. Hello,
    merci pour le Tuto mais chez moi ça bloque toujours.
    J’ai comme un doute sur la Var 2 qui est censé être le nom d’utilisateur.
    Utilisateur certes, mais lequel ? parce que j’ai un compte utilisateur Hue qui est en fait lié a mon compte google, et je viens récemment de faire un compte dev comme vu sur les forums, mais sans indications supplementaire, aucune lampe n’est lié au compte dev

    1. Sa fait quelques temps que j’ai mis en place ce tuto, mais là il s’agit d’un problème d’implantation dans EEDOMUS.
      Supprime et ré-installe les ampoules dans EEDOMUS, il te faut obligatoirement la liaison entre la BOX et ton compte Phillips Hue

      1. Oui effectivement, quelque chose à foiré lors de l’implémentation; car après avoir désinstallé et ré installé les lampes sur la box, tout c’est mis à marcher correctement..
        Encore merci 🙂

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.